Notification Delivery Issues
Incident Report for Minds
Resolved
This incident has been resolved.
Posted Aug 19, 2021 - 03:00 UTC
Investigating
We are investigating an issue with notification delivery
Posted Aug 18, 2021 - 22:57 UTC
This incident affected: API.