Minds.com Status

Old messages not appearing for multiple users.

Resolved
Messenger
Partial Outage

We are investigating reports that some users are missing their message history.

2019-08-23T18:22:45.752Z
Update

This issue was tracked via front!1810.

This incident has been resolved, and should not reoccur.