Site outage
Incident Report for Minds
Resolved
This incident has been resolved.
Posted Jul 08, 2024 - 17:40 UTC
Investigating
We are currently investigating reports of increased API latency.
Posted Jul 08, 2024 - 17:18 UTC
This incident affected: Web, API, and Search / Feeds.