Increased API Latency

Incident Report for Minds

Resolved

This incident has been resolved.
Posted Jun 09, 2021 - 20:19 UTC

Update

Latency is now returning to acceptable levels.
Posted Jun 09, 2021 - 20:17 UTC

Monitoring

Despite caching efforts, the quote counts are still very slow and causing increased latency on ElasticSearch. https://gitlab.com/minds/engine/-/commit/2f190d4c168c14a260274305a69bb89b2b619d3e is being rolled out.
Posted Jun 09, 2021 - 20:14 UTC

Investigating

We're experiencing increased latency across the site and are currently looking into the issue.
Posted Jun 09, 2021 - 20:09 UTC
This incident affected: Core services (API, Web).