Boost Views Sync Issues
Incident Report for Minds
Resolved
This incident has been resolved.
Posted Apr 19, 2024 - 19:24 UTC
Investigating
We have detected issues with Boost Partner Views and are currently investigating.
Posted Apr 19, 2024 - 18:35 UTC
This incident affected: Boost.