Notification Delivery
Incident Report for Minds
Resolved
This incident has been resolved.
Posted Apr 30, 2022 - 13:56 UTC
Investigating
We're experiencing an issue delivering notifications and are currently looking into the issue.
Posted Apr 30, 2022 - 13:30 UTC
This incident affected: Notifications.